Frontline Spatial Editor

  • Computer and processor | 4x 3,6 gigahertz (GHz) or faster, core i7-7700
  • Operating system | Windows 10 (64-bit)
  • Memory | 16 GB RAM
  • Hard disk | 2,5 GB of available disk space
  • Graphics | Nvidia Geforce GTX 1050 (4 GB VRAM)
  • Accessories | All features and functionality are available by using a keyboard, mouse, or another standard or accessible input device

Notes:

1. In some company security setups, TeamViewer must be listed as a trusted publisher so that users are able to install Spatial Editor on their workstations. Consult the IT department of your company to know if this is required.

2. Product functionality and graphics may vary based on your system configuration.

Frontline Spatial Workplace

iOS Devices with an A9 or later processor and compatibility with the ARKit

Supported devices:

  • iPhones: iPhone SE, iPhone 6s, iPhone 6s Plus, iPhone 7, iPhone 7 Plus, iPhone 8, iPhone 8 Plus, iPhone X, iPhone XR, iPhone XS, iPhone XS Max, iPhone 11, iPhone 11 Pro, iPhone 11 Pro Max, iPhone 12, iPhone 12 Pro, iPhone 12 Pro Max, iPhone 13, iPhone 13 Pro, iPhone 13 Pro Max
  • iPads:
    • iPad (5th generation or later)
      • iPad 2017 (5th generation), iPad 2018 (6th generation), iPad 2019 (7th generation), iPad 10.2-inch (2019), iPad 2020 (8th generation), iPad 2021 (9th generation)
    • iPad Pro (all models)
      • iPad Pro 9.7-inch, iPad Pro 10.5-inch, iPad Pro 12.9-inch (1st generation), iPad Pro 12.9-inch (2nd generation), iPad Pro 12.9-inch (3rd generation), iPad Pro 11-inch (1st generation), iPad Pro 12.9-inch (4th generation), iPad Pro 11-inch (2nd generation), iPad Pro 12.9-inch (5th generation), iPad Pro 11-inch (3rd generation).
    • iPad mini (5th generation), iPad mini (6th generation)
    • iPad Air (3rd generation), iPad Air (4th generation), iPad Air (5th generation)

Operating system: iOS 12 or higher

Hard disk: 200 MB of available disk space (more space is required to store your templates and tasks)

Android devices with compatibility with the ARCore

Note: For a full list of all supported devices, visit the ARCore support page on Google.

Operating system: Android 7.0 or later (some models require newer versions as noted in the list from the ARCore support page). ARMv7 devices are not supported.

Note: Although ARCore is enough for running Frontline Spatial Workplace, good processing is necessary for a smooth experience, especially concerning tracking functionalities and the display of holograms. Some older Android devices might experience lagging and considerable loading times.

Hard disk: 200 MB of available disk space (more space is required to store your templates and tasks)

Microsoft HoloLens 2

Operating system: Microsoft 10

Minimum storage available: 200 MB of available disk space for the software (more space is required to store your templates and tasks)

Spatial Workplace for Desktop

  • Computer and processor | 1.5 GHz
  • Operating system | Windows 10 (64-bit)
  • Memory | 4 GB RAM
  • Hard disk | 1 GB of available disk space

Supported file formats

CAD Files

  • IGES (.igs, .iges), STEP (.step, .stp), JT (.jt), ACIS (.sat, .sab, .asat, .asab), XCGM (.xcgm), CATIA V5 1 (.catproduct, .catpart), 3DExperience (CATIA V6) 2 (.3dxml), SolidWorks 8 (.par, .asm), SolidWorks 9, 10 (.sldprt, .sldasm), NX 5 (.prt), DFX/DWG 3 (.dwg, .dxf), Inventor 4 (.ipt, .iam), Parasolid 6 (.x_t, .x_b), VDA-FS (.vda), STL (.stl), FBX (.fbx), OBJ (.obj), Creo (.prt, .prt.*, .asm, .asm.*)

Images

  • PNG, JPG, JPEG, TIF/TIFF

Videos

  • MP4, AVI, MOV, MPEG, GIF, FLV, OGG, WMV

Audio

  • WAV

Supported Languages

Language Spatial Editor Spatial Workplace (Workflow Translations)

Chinese

-

(tick)

English

(tick)

(tick)

French

-

(tick)

German

-

(tick)

Japanese

-

(tick)

Korean

-

(tick)

Portuguese Brazil

-

(tick)

Spanish

-

(tick)